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Using This Manual
This preface is divided into the following sections:
1. What’s In This Manual
2.The Contents of the FLUENT Manuals
3. Where to Find the Files Used in the Tutorials
4. How To Use This Manual
5.Typographical Conventions Used In This Manual

1. What’s In This Manual
The ANSYS FLUENT Tutorial Guide contains a number of tutorials that teach you how to use ANSYS
FLUENT to solve different types of problems. In each tutorial, features related to problem setup and
postprocessing are demonstrated.
The tutorials are written with the assumption that you have completed one or more of the introductory
tutorials found in this manual:
•

Introduction to Using ANSYS FLUENT in ANSYS Workbench: Fluid Flow and Heat Transfer in a Mixing
Elbow (p. 1)

•

Parametric Analysis in ANSYS Workbench Using ANSYS FLUENT (p. 77)

•

Introduction to Using ANSYS FLUENT: Fluid Flow and Heat Transfer in a Mixing Elbow (p. 131)

and that you are familiar with the ANSYS FLUENT navigation pane and menu structure. Some steps in
the setup and solution procedure will not be shown explicitly.
Introduction to Using ANSYS FLUENT: Fluid Flow and Heat Transfer in a Mixing Elbow (p. 131)
All of the tutorials include some postprocessing instructions, but Postprocessing (p. 1059) is devoted entirely
to postprocessing.

2. The Contents of the FLUENT Manuals
The manuals listed below form the FLUENT product documentation set. They include descriptions of
the procedures, commands, and theoretical details needed to use FLUENT products.
FLUENT Getting Started Guide contains general information about getting started with using
FLUENT.
FLUENT User's Guide contains detailed information about using FLUENT, including information
about the user interface, reading and writing files, defining boundary conditions, setting up
physical models, calculating a solution, and analyzing your results.
FLUENT in Workbench User's Guide contains information about getting started with and using
FLUENT within the Workbench environment.
FLUENT Theory Guide contains reference information for how the physical models are implemented in FLUENT.
FLUENT UDF Manual contains information about writing and using user-defined functions
(UDFs).
FLUENT Tutorial Guide contains a number of example problems with detailed instructions,
commentary, and postprocessing of results.
FLUENT Text Command List contains a brief description of each of the commands in FLUENT’s
text interface.
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FLUENT Adjoint Solver Module Manual contains information about the background and usage
of FLUENT's Adjoint Solver Module that allows you to obtain detailed sensitivity data for the
performance of a fluid system.
FLUENT Battery Module Manual contains information about the background and usage of
FLUENT's Battery Module that allows you to analyze the behavior of electric batteries.
FLUENT Continuous Fiber Module Manual contains information about the background and usage
of FLUENT's Continuous Fiber Module that allows you to analyze the behavior of fiber flow,
fiber properties, and coupling between fibers and the surrounding fluid due to the strong interaction that exists between the fibers and the surrounding gas.
FLUENT Fuel Cell Modules Manual contains information about the background and the usage
of two separate add-on fuel cell models for FLUENT that allow you to model polymer electrolyte
membrane fuel cells (PEMFC), solid oxide fuel cells (SOFC), and electrolysis with FLUENT.
FLUENT Magnetohydrodynamics (MHD) Module Manual contains information about the background and usage of FLUENT's Magnetohydrodynamics (MHD) Module that allows you to analyze
the behavior of electrically conducting fluid flow under the influence of constant (DC) or oscillating (AC) electromagnetic fields.
FLUENT Migration Manual contains information about transitioning from the previous release
of FLUENT, including details about new features, solution changes, and text command list
changes.
FLUENT Population Balance Module Manual contains information about the background and
usage of FLUENT's Population Balance Module that allows you to analyze multiphase flows involving size distributions where particle population (as well as momentum, mass, and energy)
require a balance equation.
Running FLUENT Under LSF contains information about the using FLUENT with Platform Computing’s LSF software, a distributed computing resource management tool.
Running FLUENT Under PBS Professional contains information about the using FLUENT with
Altair PBS Professional, an open workload management tool for local and distributed environments.
Running FLUENT Under SGE contains information about the using FLUENT with Sun Grid Engine
(SGE) software, a distributed computing resource management tool.

3. Where to Find the Files Used in the Tutorials
Each of the tutorials uses an existing mesh file. (Tutorials for mesh generation are provided with the
mesh generator documentation.) You will find the appropriate mesh file (and any other relevant files
used in the tutorial) on the ANSYS Customer Portal. The “Preparation” step of each tutorial will tell you
where to find the necessary files. (Note that Tutorials Postprocessing (p. 1059) and Parallel Processing (p. 1113)
use existing case and data files.)
Some of the more complex tutorials may require a significant amount of computational time. If you
want to look at the results immediately, without waiting for the calculation to finish, final solution files
are provided in a solution_files folder which you can access after extracting the tutorial input
archive.

4. How To Use This Manual
Depending on your familiarity with computational fluid dynamics and the ANSYS FLUENT software, you
can use this tutorial guide in a variety of ways.

xiv
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4.1. For the Beginner
If you are a beginning user of ANSYS FLUENT you should first read and solve Tutorial 1, in order to familiarize yourself with the interface and with basic setup and solution procedures. You may then want
to try a tutorial that demonstrates features that you are going to use in your application. For example,
if you are planning to solve a problem using the non-premixed combustion model, you should look at
Using the Non-Premixed Combustion Model (p. 717).
You may want to refer to other tutorials for instructions on using specific features, such as custom field
functions, mesh scaling, and so on, even if the problem solved in the tutorial is not of particular interest
to you. To learn about postprocessing, you can look at Postprocessing (p. 1059), which is devoted entirely
to postprocessing (although the other tutorials all contain some postprocessing as well).

4.2. For the Experienced User
If you are an experienced ANSYS FLUENT user, you can read and/or solve the tutorial(s) that demonstrate
features that you are going to use in your application. For example, if you are planning to solve a
problem using the non-premixed combustion model, you should look at Using the Non-Premixed Combustion Model (p. 717).
You may want to refer to other tutorials for instructions on using specific features, such as custom field
functions, mesh scaling, and so on, even if the problem solved in the tutorial is not of particular interest
to you. To learn about postprocessing, you can look at Postprocessing (p. 1059), which is devoted entirely
to postprocessing (although the other tutorials all contain some postprocessing as well).

5. Typographical Conventions Used In This Manual
Several typographical conventions are used in the text of the tutorials to facilitate your learning process.
•

Different type styles are used to indicate graphical user interface menu items and text interface menu
items (e.g., Zone Surface dialog box, surface/zone-surface command).

•

The text interface type style is also used when illustrating exactly what appears on the screen or exactly
what you must type in the text window or in a dialog box.

•

Instructions for performing each step in a tutorial will appear in standard type. Additional information
about a step in a tutorial appears in italicized type.

•

A mini flow chart is used to guide you through the navigation pane, which leads you to a specific task
page or dialog box. For example,
Models →

Multiphase → Edit...

indicates that Models is selected in the navigation pane, which then opens the corresponding task
page. In the Models task page, Multiphase is selected from the list. Clicking the Edit... button
opens the Multiphase dialog box.
Also, a mini flow chart is used to indicate the menu selections that lead you to a specific command
or dialog box. For example,
Define → Injections...
indicates that the Injections... menu item can be selected from the Define pull-down menu.
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The words surrounded by boxes invoke menus (or submenus) and the arrows point from a specific
menu toward the item you should select from that menu.

xvi
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Chapter 1: Introduction to Using ANSYS FLUENT in ANSYS
Workbench: Fluid Flow and Heat Transfer in a Mixing Elbow
This tutorial is divided into the following sections:
1.1. Introduction
1.2. Prerequisites
1.3. Problem Description
1.4. Setup and Solution

1.1. Introduction
This tutorial illustrates using ANSYS FLUENT fluid flow systems in ANSYS Workbench to set up and solve
a three-dimensional turbulent fluid-flow and heat-transfer problem in a mixing elbow. It is designed to
introduce you to the ANSYS Workbench tool set using a simple geometry. Guided by the steps that
follow, you will create the elbow geometry and the corresponding computational mesh using the
geometry and meshing tools within ANSYS Workbench. You will use ANSYS FLUENT to set up and solve
the CFD problem, then visualize the results in both ANSYS FLUENT and in the CFD-Post postprocessing
tool. Some capabilities of ANSYS Workbench (for example, duplicating fluid flow systems, connecting
systems, and comparing multiple data sets) are also examined in this tutorial.
This tutorial demonstrates how to do the following:
•

Launch ANSYS Workbench.

•

Create a FLUENT fluid flow analysis system in ANSYS Workbench.

•

Create the elbow geometry using ANSYS DesignModeler.

•

Create the computational mesh for the geometry using ANSYS Meshing.

•

Set up the CFD simulation in ANSYS FLUENT, which includes:
–

Setting material properties and boundary conditions for a turbulent forced-convection problem.

–

Initiating the calculation with residual plotting.

–

Calculating a solution using the pressure-based solver.

–

Examining the flow and temperature fields using ANSYS FLUENT and CFD-Post.

•

Create a copy of the original FLUENT fluid flow analysis system in ANSYS Workbench.

•

Change the geometry in ANSYS DesignModeler, using the duplicated system.

•

Regenerate the computational mesh.

•

Recalculate a solution in ANSYS FLUENT.

•

Compare the results of the two calculations in CFD-Post.

1.2. Prerequisites
This tutorial assumes that you have little to no experience with ANSYS Workbench, ANSYS DesignModeler,
ANSYS Meshing, ANSYS FLUENT, or CFD-Post, and so each step will be explicitly described.
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
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1.3. Problem Description
The problem to be considered is shown schematically in Figure 1.1 (p. 2). A cold fluid at 293.15 K flows
into the pipe through a large inlet and mixes with a warmer fluid at 313.15 K that enters through a
smaller inlet located at the elbow. The mixing elbow configuration is encountered in piping systems in
power plants and process industries. It is often important to predict the flow field and temperature field
in the area of the mixing region in order to properly design the junction.

Note
Because the geometry of the mixing elbow is symmetric, only half of the elbow needs to be
modeled.

Figure 1.1 Problem Specification

1.4. Setup and Solution
The following sections describe the setup and solution steps for this tutorial:
1.4.1. Preparation
1.4.2. Step 1: Creating a FLUENT Fluid Flow Analysis System in ANSYS Workbench
1.4.3. Step 2: Creating the Geometry in ANSYS DesignModeler
1.4.4. Step 3: Meshing the Geometry in the ANSYS Meshing Application
1.4.5. Step 4: Setting Up the CFD Simulation in ANSYS FLUENT
1.4.6. Step 5: Displaying Results in ANSYS FLUENT and CFD-Post
2
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1.4.7. Step 6: Duplicating the FLUENT-Based Fluid Flow Analysis System
1.4.8. Step 7: Changing the Geometry in ANSYS DesignModeler
1.4.9. Step 8: Updating the Mesh in the ANSYS Meshing Application
1.4.10. Step 9: Calculating a New Solution in ANSYS FLUENT
1.4.11. Step 10: Comparing the Results of Both Systems in CFD-Post
1.4.12. Step 11: Summary

1.4.1. Preparation
To prepare for running this tutorial, set up a working folder on the computer you will be using. You
can also download some files from the ANSYS Customer Portal web page, which you can reach via
the Customer Portal link on the ANSYS Website at http://www.ansys.com.
1.

Obtain the Tutorial Inputs Archive from the ANSYS Customer Portal.
a.

On the Customer Portal Home page, click Download Software. This takes you to the ANSYS
Download Center Wizard.

b.

Click Next Step.

c.

Choose a Download Type. Select the Current Release and Updates radio button.

d.

Click Next Step.

e.

Choose the Hardware Platform you are using.

f.

Click Next Step.

g.

At the bottom of the page, under the heading ANSYS Documentation and Examples, check the
box next to ANSYS Fluid Dynamics Tutorial Inputs.

h.

Click Next Step.

i.

Click the ANSYS Fluid Dynamics Tutorial Inputs link to download the ANSYS_Fluid_Dynamics_Tutorial_Inputs.zip file.

j.

Save and extract the .zip file to any convenient location. Tutorial mesh and solution files for
each of the ANSYS Fluid Dynamics products are located in v140\Tutorial_Inputs\Fluid_Dynamics\<product>.

2.

Copy the elbow-workbench.zip file from the FLUENT sub-folder of the ANSYS_Fluid_Dynamics_Tutorial_Inputs.zip archive.

3.

Unzip elbow-workbench.zip to your working folder. This file contains a folder, elbow-workbench,
that holds four items:
•

Two geometry files, elbow_geometry.agdb and elbow_geometry.stp

•

An ANSYS Workbench project file, elbow-workbench.wbpj

•

A project folder (elbow-workbench_files) containing supporting files such as solution and
results files

Note
ANSYS FLUENT tutorials are prepared using ANSYS FLUENT on a Windows system. The screen
shots and graphic images in the tutorials may be slightly different than the appearance on
your system, depending on the operating system or graphics card.
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1.4.2. Step 1: Creating a FLUENT Fluid Flow Analysis System in ANSYS Workbench
In this step, you will start ANSYS Workbench, create a new FLUENT fluid flow analysis system, then review
the list of files generated by ANSYS Workbench.
1.

Start ANSYS Workbench by clicking the Windows Start menu, then selecting the Workbench 14.0
option in the ANSYS 14.0 program group.
Start → All Programs → ANSYS 14.0 → Workbench 14.0
This displays the ANSYS Workbench application window, which has the Toolbox on the left and
the Project Schematic to its right. Various supported applications are listed in the Toolbox and
the components of the analysis system will be displayed in the Project Schematic.

Note
When you first start ANSYS Workbench, the Getting Started pop-up window is displayed, offering assistance through the online help for using the application. You can
keep the window open, or close it by clicking the ‘X’ icon in the upper right-hand
corner. If you need to access the online help at any time, use the Help menu, or press
the F1 key.
2.

4

Create a new FLUENT fluid flow analysis system by double-clicking the Fluid Flow (FLUENT) option
under Analysis Systems in the Toolbox.
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Figure 1.2 Selecting the Fluid Flow (FLUENT) Analysis System in ANSYS Workbench
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This creates a new FLUENT-based fluid flow analysis system in the Project Schematic.

Tip
You can also drag-and-drop the analysis system into the Project Schematic. A green
dotted outline indicating a potential location for the new system initially appears in
the Project Schematic. When you drag the system to one of the outlines, it turns into
a red box to indicate the chosen location of the new system.

Figure 1.3 ANSYS Workbench with a New FLUENT-Based Fluid Flow Analysis System

3.

4.

Name the analysis.
a.

Double-click the Fluid Flow (FLUENT) label underneath the analysis system (if it is not already
highlighted).

b.

Enter elbow for the name of the analysis system.

Save the project.
a.

Select the Save option under the File menu in ANSYS Workbench.
File → Save
This displays the Save As dialog box, where you can browse to your working folder and enter
a specific name for the ANSYS Workbench project.

b.

In your working directory, enter elbow-workbench as the project File name and click the Save
button to save the project. ANSYS Workbench saves the project with a .wbpj extension and also
saves supporting files for the project.
Note that the fluid flow analysis system is composed of various cells (Geometry, Mesh, etc.)
that represent the workflow for performing the analysis. ANSYS Workbench is composed of
multiple data-integrated and native applications in a single, seamless project flow, where
individual cells can obtain data from other cells and provide data to other cells. As a result
of this constant flow of data, a cell’s state can quickly change. ANSYS Workbench provides a

6

Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.

Setup and Solution
visual indication of a cell’s state at any given time via icons on the right side of each cell.
Brief descriptions of the various states are provided below:
•

Unfulfilled ( ) indicates that required upstream data does not exist. For example, when you
first create a new Fluid Flow (FLUENT) analysis system, all cells downstream of the Geometry
cell appear as Unfulfilled because you have not yet specified a geometry for the system.

•

Refresh Required ( ) indicates that upstream data has changed since the last refresh or update. For example, after you assign a geometry to the geometry cell in your new Fluid Flow
(FLUENT) analysis system, the Mesh cell appears as Refresh Required since the geometry
data has not yet been passed from the Geometry cell to the Mesh cell.

•

Attention Required ( ) indicates that the current upstream data has been passed to the cell,
however, you must take some action to proceed. For example, after you launch ANSYS FLUENT from the Setup cell in a Fluid Flow (FLUENT) analysis system that has a valid mesh, the
Setup cell appears as Attention Required because additional data must be entered in ANSYS
FLUENT before you can calculate a solution.

•

Update Required ( ) indicates that local data has changed and the output of the cell needs
to be regenerated. For example, after you launch ANSYS Meshing from the Mesh cell in a
Fluid Flow (FLUENT) analysis system that has a valid geometry, the Mesh cell appears as
Update Required because the Mesh cell has all the data it needs to generate an ANSYS
FLUENT mesh file, but the ANSYS FLUENT mesh file has not yet been generated.

•

Up To Date ( ) indicates that an update has been performed on the cell and no failures have
occurred or that an interactive calculation has been completed successfully. For example, after
ANSYS FLUENT finishes performing the number of iterations that you request, the Solution
cell appears as Up-to-Date.

•

Interrupted ( ) indicates that you have interrupted an update (or canceled an interactive
calculation that is in progress). For example, if you select the Cancel button in ANSYS FLUENT while it is iterating, ANSYS FLUENT completes the current iteration and then the Solution
cell appears as Interrupted.

•

) indicates that the cell is locally up-to-date, but may change
Input Changes Pending (
when next updated as a result of changes made to upstream cells. For example, if you change
the Mesh in an Up-to-Date Fluid Flow (FLUENT) analysis system, the Setup cell appears as
Refresh Required, and the Solution and Results cells appear as Input Changes Pending.

•

Pending ( ) indicates that a batch or asynchronous solution is in progress. When a cell
enters the Pending state, you can interact with the project to exit Workbench or work
with other parts of the project. If you make changes to the project that are upstream of
the updating cell, then the cell will not be in an up-to-date state when the solution
completes.

For more information about cell states, see Understanding Cell States.
5.

View the list of files generated by ANSYS Workbench.
ANSYS Workbench allows you to easily view the files associated with your project using the Files
view. To open the Files view, select the Files option under the View menu at the top of the ANSYS
Workbench window.
View → Files
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Figure 1.4 ANSYS Workbench Files View for the Project After Adding a FLUENT-Based
Fluid Flow Analysis System

In the Files view, you will be able to see the name and type of file, the ID of the cell that the file
is associated with, the size of the file, the location of the file, and other information. For more information about the Files view, see Files View.
From here, you will create the geometry described in Figure 1.1 (p. 2), and later create a mesh
and set up a fluid flow analysis for the geometry.

1.4.3. Step 2: Creating the Geometry in ANSYS DesignModeler
For the geometry of your fluid flow analysis, you can create a geometry in ANSYS DesignModeler, or
import the appropriate geometry file. In this step, you will create the geometry in ANSYS DesignModeler,
then review the list of files generated by ANSYS Workbench.

Important
Note the Attention Required icon ( ) within the Geometry cell for the system. This
indicates that the cell requires data (for example, a geometry). Once the geometry is
defined, the state of the cell will change accordingly. Likewise, the state of some of the
remaining cells in the system will change.

Note
If you would rather not create the geometry in ANSYS DesignModeler, you can import a preexisting geometry by right-clicking the Geometry cell and selecting the Import Geometry
option from the context menu. From there, you can browse your file system to locate the
elbow_geometry.agdb geometry file that is provided for this tutorial. If you do not have
access to ANSYS DesignModeler, you can use the elbow_geometry.stp file instead.
To learn how to create a mesh from the geometry you imported, go to Step 3: Meshing the
Geometry in the ANSYS Meshing Application (p. 19).
1.

Start ANSYS DesignModeler.
In the ANSYS Workbench Project Schematic, double-click the Geometry cell in the elbow fluid
flow analysis system. This displays the ANSYS DesignModeler application.

8
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Tip
You can also right-click the Geometry cell to display the context menu, then select
New Geometry...
2.

Set the units in ANSYS DesignModeler.
When ANSYS DesignModeler first appears, you are prompted to select the desired system of length
units to work from. For the purposes of this tutorial (where you will create the geometry in inches
and perform the CFD analysis using SI units), select Inch as the desired length unit and click OK
to close the prompt.

Figure 1.5 Setting the Units in ANSYS DesignModeler

3.

Create the geometry.
The geometry for this tutorial (Figure 1.1 (p. 2)) consists of a large curved pipe accompanied by
a smaller side pipe. To create the larger main pipe, you will use the Sweep operation. Sweeping
requires the use of two sketches; one that defines the profile to be swept and the other that
defines the path through which the profile is to be swept. In this case, the profile is a half circle
because the symmetry of the problem means that you do not have to generate the entire pipe
geometry.
a.

Set up the plane:
i.

Create a new plane by selecting YZPlane from the Tree Outline, then clicking the New Plane
icon
in the Active Plane/Sketch toolbar near the top of the ANSYS Workbench window.
Selecting YZPlane before you create the new plane ensures that the new plane is based on
the YZPlane.
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ii.

In the Details View for the new plane (Plane4), set Transform1 (RMB) to Offset Global X
by clicking the word None to the right of Transform1 (RMB) and selecting Offset Global X
from the drop-down menu. Set the Value of the offset to -8 in by clicking the 0 to the right
of FD1, Value 1 and entering -8. Note that the inches measurement appears automatically
when you click outside of this box.

iii.

To create the plane, click the Generate button
DesignModeler toolbar.

iv.

Create a new sketch by selecting Plane4 from the Tree Outline and then clicking the New

which is located in the ANSYS

Sketch icon
in the Active Plane/Sketch toolbar, near the top of the ANSYS Workbench window. Selecting the plane first ensures that the new sketch is based on Plane4.

10
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b.

c.

Set up the grid:
i.

On the Sketching tab of the Tree Outline, open the Settings toolbox, select Grid, and enable
the Show in 2D and the Snap options.

ii.

Set Major Grid Spacing to 1 inch and Minor-Steps per Major to 2.

Create the profile:
i.

Zoom in on the center of the grid so that you can see the grid lines clearly. You can do this
by holding down the right mouse button and dragging a box over the desired viewing area.
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
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ii. On the Sketching tab, open the Draw toolbox and select Arc by Center (you may need to
use the arrows in the toolbox to scroll down to see the correct tool). You will be drawing an
arc with a radius of 2 inches, centered on Y=- 6 inches, Z=0 inches (located below the origin
of Plane4). The grid settings that you have just set up will help you to position the arc and
set its radius correctly.
To create the arc, click the point where you want to create the center of the circle (in
this case, Y=- 6 inches, Z=0 inches). Then click the point where you want to start drawing
the arc (in this case Y=- 4 inches, Z=0 inches). At this stage, when you drag the unclicked
mouse, DesignModeler will create an arc with a fixed radius. With the mouse button
unclicked, drag through an arc of 180°. Click on Y=- 8 inches, Z=0 inches to stop the
drawing process. Your drawing should now resemble Figure 1.6 (p. 13)
iii.
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Next you will close the half-circle with a line that joins the two arc ends. On the Sketching
tab, in the Draw toolbox, select Line (you may need to use the arrows in the toolbox to scroll
up to see the correct tool). Draw a line from Y=- 4 inches, Z=0 inches to Y=- 8 inches, Z=0
inches. This closed half-circle will be used as the profile during the sweep.
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Figure 1.6 Creating the Arc Profile

d.

Create the path:
i.

On the Modeling tab select XYPlane, then click the New Sketch icon and then the Generate
button to create a new sketch based on the XYPlane.

ii.

On the Sketching tab, open the Settings toolbox, select Grid, and enable the Show in 2D
and the Snap options.

iii.

Set Major Grid Spacing to 1 inch and Minor-Steps per Major to 2.

iv.

In the Draw toolbox, select Line to draw two straight lines on the sketch. For reference, the
coordinates of the endpoints of the lines are ( = − inches, = − inches), ( = inches,
 = − inches) for the horizontal line and ( = inches, = inches), ( = inches,
 = inches) for the vertical line.

v.

In the Draw toolbox, select Arc by Center and click once on the origin (center of the arc).
Now click once on the point  = inches, = inches to select one of the end points of
the arc. With the mouse unclicked, move the mouse around to the other end point
Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
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( = inches, = − inches) and click it to draw the quarter-circle. If the wrong part of the
arc is drawn and it does not resemble Figure 1.7 (p. 14), click Undo from the Undo/Redo
toolbar and try again. Together, the arc and the two straight lines form a curving line that is
the path through which the half-circle profile will be swept.

Figure 1.7 Creating the Elbow Path

e.
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Create the pipe:
from the 3D Features toolbar.

i.

Select the Sweep button

ii.

Set the Profile to be Sketch1 by clicking Sketch1 in the Tree Outline and then clicking
Apply next to Profile in the Details View at the bottom-left of the screen.

iii.

Set the Path to Sketch2: Click Sketch2 in the Tree Outline, then click the Not selected text
next to Path in the Details View and click Apply.

iv.

Click the Generate button to create the pipe.
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Figure 1.8 Generating the Pipe

f.

View and manipulate the image:
You can use the mouse buttons to change your view of this 3D image. The following table
describes mouse actions that are available:

Table 1.1 DesignModeler View Manipulation Instructions
Action

Using Graphics Toolbar Buttons and the Mouse

Rotate view
(vertical,
horizontal)

After clicking the Rotate icon,
, press and hold the left mouse button
and drag the mouse. Dragging side to side rotates the view about the
vertical axis, and dragging up and down rotates the view about the horizontal axis.
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Action

Using Graphics Toolbar Buttons and the Mouse

Translate
or pan
view

After clicking the Pan icon,
, press and hold the left mouse button and
drag the object with the mouse until the view is satisfactory.

Zoom in and
out of
view

After clicking the Zoom icon,
, press and hold the left mouse button
and drag the mouse up and down to zoom in and out of the view.

Box
zoom

, press and hold the left mouse
After clicking the Box Zoom icon,
button and drag the mouse diagonally across the screen. This action will
cause a rectangle to appear in the display. When you release the mouse
button, a new view will be displayed which consists entirely of the contents
of the rectangle.

Clicking the Zoom to Fit icon,
window.
g.
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, will cause the object to fit exactly and be centered in the

Create the side pipe:
i.

Create a new plane based on the ZXPlane. As before, first make the ZXPlane active by
clicking on it, then click the New Plane icon to create the plane based upon it.

ii.

In the Details View, set Transform 1 (RMB) to Offset Global X, and set the FD1, Value 1
of the offset to 5.5 inches.

iii.

Set Transform 2 (RMB) to Offset Global Y and the FD2, Value 2 of the offset to -9 inches.

iv.

Click Generate to create the plane.

v.

With the new plane selected in the Tree Outline, click the New Sketch icon.

vi.

As with the main pipe, a profile will be created, but with the side pipe, the Extrude operation
will be used to create the body of the pipe. On the Sketching tab, open the Draw toolbox
and select Arc by Center. You will be drawing a 180° arc that is centered on the origin, with
the two ends on the X axis. The radius for this arc will be adjusted later, so you can use any
convenient radius for now. Click once on the origin, then once some distance along the X
axis in either a positive or a negative direction. With the mouse button unclicked, draw an
arc to the opposite side of the origin and click the X axis again.

Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.

Setup and Solution
vii. To adjust the radius, open the Dimensions toolbox on the Sketching tab and select Radius.
Click once on the curve of the arc you have just created then click once on the radius (anywhere between the arc and the origin). In the Details View under the Dimensions: 1 section,
set the radius, R1 to 0.5 inches.

viii. Next you will close the half-circle with a line that joins the two arc ends. On the Sketching
tab, in the Draw toolbox, select Line. Draw a line connecting the open ends of the arc. This
closed half-circle will be used as the profile for the extrude operation.
from the 3D Features toolbar.

ix.

Click the Extrude button

x.

In the Details View, set Geometry to be the new sketch (Sketch3), and set Operation to
Add Material.

xi.

Set Direction to Normal and Extent Type to Fixed. Set FD1, Depth (>0) to 4 inches.

xii. Click Generate to create the side pipe.
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Figure 1.9 Generating the Additional Pipe

h.
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Specify the geometry as a fluid body.
i.

In the Tree Outline, open the 1 Part, 1 Body branch and select Solid.

ii.

In the Details View of the body, change the name of the Body from Solid to Fluid.

iii.

In the Fluid/Solid section, select Fluid.
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iv.

Click Generate.

4.

Close ANSYS DesignModeler by selecting File → Close DesignModeler or by clicking the ‘X’ icon in
the upper right-hand corner. ANSYS Workbench automatically saves the geometry and updates the
Project Schematic accordingly. The question mark in the Geometry cell is replaced by a check mark,
indicating that there is a geometry now associated with the fluid flow analysis system.

5.

View the list of files generated by ANSYS Workbench by selecting View → Files.

Figure 1.10 ANSYS Workbench Files View for the Project After Creating the Geometry

Note the addition of the geometry file (FFF.agdb, where FFF indicates a FLUENT-based fluid
flow system) to the list of files. If you had imported the geometry file provided for this tutorial
rather than creating the geometry yourself, the elbow_geometry.agdb (or the elbow_geometry.stp) file would be listed instead.

1.4.4. Step 3: Meshing the Geometry in the ANSYS Meshing Application
Now that you have created the mixing elbow geometry, you need to generate a computational mesh
for throughout the flow volume. For this section of the tutorial, you will use the ANSYS Meshing application to create a mesh for your CFD analysis, then review the list of files generated by ANSYS Workbench.
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Important
Note the Refresh Required icon ( ) within the Mesh cell for the system. This indicates
that the state of the cell requires a refresh and that upstream data has changed since
the last refresh or update (such as an update to the geometry). Once the mesh is defined,
the state of the Mesh cell will change accordingly, as will the state of the next cell in
the system, in this case the Setup cell.

1.

Open the ANSYS Meshing application.
In the ANSYS Workbench Project Schematic, double-click the Mesh cell in the elbow fluid flow
analysis system (cell A3). This displays the ANSYS Meshing application with the elbow geometry
already loaded. You can also right-click the Mesh cell to display the context menu where you can
select the Edit... option.

20
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Figure 1.11 The ANSYS Meshing Application with the Elbow Geometry Loaded

Important
The first time you open the ANSYS Meshing application, the Meshing Options are
displayed on the right-hand side of the application window. For this tutorial, no
meshing options need to be set, so click OK to close the Meshing Options pane.
2.

Create named selections for the geometry boundaries.
In order to simplify your work later on in ANSYS FLUENT, you should label each boundary in the
geometry by creating named selections for the pipe inlets, the outlet, and the symmetry surface
(the outer wall boundaries are automatically detected by ANSYS FLUENT).
a.

Select the large inlet in the geometry that is displayed in the ANSYS Meshing application.

Tip
Use the Graphics Toolbar buttons and the mouse to manipulate the image until
you can easily see the pipe openings and surfaces.
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Tip
To select the inlet, the Single select (

b.

) mode must be active.

Right-click and select the Create Named Selection option.

Figure 1.12 Selecting a Face to Name

This displays the Selection Name dialog box.
22
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Figure 1.13 Applying a Name to a Selected Face

c.

In the Selection Name dialog box, enter velocity-inlet-large for the name and click OK.

d.

Perform the same operations for:
•

The small inlet (velocity-inlet-small)

•

The large outlet (pressure-outlet)

•

The symmetry planes (symmetry).

Note
To select multiple planes, hold down the Ctrl key and select the individual
planes in the graphics window.

Important
It is important to note that by using the strings “velocity inlet” and “pressure outlet”
in the named selections (with or without hyphens or underscore characters), ANSYS
FLUENT automatically detects and assigns the corresponding boundary types accordingly.
3.

Set some basic meshing parameters for the ANSYS Meshing application.
For this analysis, you will adjust several meshing parameters to obtain a finer mesh.
a.

In the Outline view, select Mesh under Project/Model to display the Details of “Mesh” view
below the Outline view.
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Important
Note that because the ANSYS Meshing application automatically detects that
you are going to perform a CFD fluid flow analysis using ANSYS FLUENT, the
Physics Preference is already set to CFD and the Solver Preference is already
set to Fluent.
b.

c.

Expand the Sizing node by clicking the “+” sign to the left of the word Sizing to reveal additional
sizing parameters.
i.

Change Relevance Center to Fine by clicking the on the default value, Coarse, and selecting
Fine from the drop down list.

ii.

Change Smoothing to High

iii.

Change Curvature Normal Angle to 10°.

Add a Body Sizing control.
i.

With Mesh still selected in the Outline tree, change the selection filter to Body in the
Graphics Toolbar (

).

ii.

Click the elbow in the graphics display to select it.

iii.

Right click in the graphics area and select Insert → Sizing from the context menu.

A new Body Sizing entry appears under Mesh in the project Outline tree
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iv.

Click the new Body Sizing control in the Outline tree.

v.

Enter 6e-3 for Element Size.
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d.
4.

Click again on Mesh in the Outline view and expand the Inflation node to reveal additional inflation parameters. Change Use Automatic Inflation to Program Controlled.

Generate the mesh.
Right-click Mesh in the project Outline tree, and select Update in the context menu.

Figure 1.14 The Computational Mesh for the Elbow Geometry in the ANSYS
Meshing Application

Important
Using the Generate Mesh option creates the mesh, but does not actually create
the relevant mesh files for the project and is optional if you already know that the
mesh is acceptable. Using the Update option automatically generates the mesh,
creates the relevant mesh files for your project, and updates the ANSYS Workbench cell that references this mesh.
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Note
Once the mesh is generated, you can view the mesh statistics by opening the Statistics
node in the Details of “Mesh” view. This will display information such as the number
of nodes and the number of elements.
5.

Close the ANSYS Meshing application.
You can close the ANSYS Meshing application without saving it because ANSYS Workbench automatically saves the mesh and updates the Project Schematic accordingly. The Refresh Required
icon in the Mesh cell has been replaced by a check mark, indicating that there is a mesh now
associated with the fluid flow analysis system.

6.

View the list of files generated by ANSYS Workbench.
View → Files

Figure 1.15 ANSYS Workbench Files View for the Project After Mesh Creation

Note the addition of the mesh files (FFF.msh and FFF.mshdb) to the list of files. The FFF.msh
file is created when you update the mesh, and the FFF.mshdb file is generated when you close
the ANSYS Meshing application.

1.4.5. Step 4: Setting Up the CFD Simulation in ANSYS FLUENT
Now that you have created a computational mesh for the elbow geometry, in this step you will set up
a CFD analysis using ANSYS FLUENT, then review the list of files generated by ANSYS Workbench.
1.

Start ANSYS FLUENT.
In the ANSYS Workbench Project Schematic, double-click the Setup cell in the elbow fluid flow
analysis system. You can also right-click the Setup cell to display the context menu where you
can select the Edit... option.
When ANSYS FLUENT is first started, the FLUENT Launcher is displayed, enabling you to view
and/or set certain ANSYS FLUENT start-up options.
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Note
The FLUENT Launcher allows you to decide which version of ANSYS FLUENT you will
use, based on your geometry and on your processing capabilities.

Figure 1.16 FLUENT Launcher

a.

Ensure that the proper options are enabled.

Important
Note that the Dimension setting is already filled in and cannot be changed,
since ANSYS FLUENT automatically sets it based on the mesh or geometry for
the current system.
i.

Make sure that Serial from the Processing Options list is enabled.

ii.

Make sure that the Display Mesh After Reading, Embed Graphics Windows, and Workbench
Color Scheme options are enabled.

Note
An option is enabled when there is a check mark in the check box, and disabled when the check box is empty. To change an option from disabled to
enabled (or vice versa), click the check box or the text.
iii.
b.

Make sure that the Double Precision option is disabled.

Click OK to launch ANSYS FLUENT.
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Figure 1.17 The ANSYS FLUENT Application

Note
The mesh is automatically loaded and displayed in the graphics window by default.
2.

Set some general settings for the CFD analysis.

Note
Select General in the navigation pane to perform the mesh-related activities and to
choose a solver.
General
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a.

Change the units for length.
Because you want to specify and view values based on a unit of length in inches from within
ANSYS FLUENT, change the units of length within ANSYS FLUENT from meters (the default)
to inches.

Important
Note that the ANSYS Meshing application automatically converts and exports
meshes for ANSYS FLUENT using meters (m) as the unit of length regardless
of what units were used to create them. This is so you do not have to scale
the mesh in ANSYS FLUENT under ANSYS Workbench.
General → Units...
This displays the Set Units dialog box.
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i.

Select length in the Quantities list.

ii.

Select in in the Units list.

iii.

Close the dialog box.

Note
Now, all subsequent inputs that require a value based on a unit of length can be
specified in inches rather than meters.
b.

Check the mesh.
General → Check

Note
ANSYS FLUENT will report the results of the mesh check in the console.
Domain Extents:
x-coordinate: min (m) = -2.032000e-01, max (m) = 2.032000e-01
y-coordinate: min (m) = -2.286000e-01, max (m) = 2.032000e-01
z-coordinate: min (m) = -2.332952e-18, max (m) = 5.080000e-02
Volume statistics:
minimum volume (m3): 1.148430e-10
maximum volume (m3): 5.741104e-08
total volume (m3): 2.633922e-03
Face area statistics:
minimum face area (m2): 2.147325e-07
maximum face area (m2): 3.444069e-05
Checking mesh.........................
Done.
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Note
The minimum and maximum values may vary slightly when running on different
platforms. The mesh check will list the minimum and maximum x and y values
from the mesh in the default SI unit of meters. It will also report a number of
other mesh features that are checked. Any errors in the mesh will be reported at
this time. Ensure that the minimum volume is not negative as ANSYS FLUENT
cannot begin a calculation when this is the case.
3.

Set up your models for the CFD simulation.
Models

a.

Enable heat transfer by activating the energy equation.
Models →

Energy → Edit...
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Note
You can also double-click a list item in order to open the corresponding dialog
box.

b.

i.

Enable the Energy Equation option.

ii.

Click OK to close the Energy dialog box.

Enable the -  turbulence model.
Models →

i.

Viscous → Edit...

Select k-epsilon from the Model list.

Note
The Viscous Model dialog box will expand.
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ii.

Use the default Standard from the k-epsilon Model list.

iii.

Select Enhanced Wall Treatment for the Near-Wall Treatment.

Note
The default Standard Wall Functions are generally applicable if the first cell
center adjacent to the wall has a y+ larger than 30. In contrast, the Enhanced
Wall Treatment option provides consistent solutions for all y+ values. Enhanced
Wall Treatment is recommended when using the k-epsilon model for general
single-phase fluid flow problems. For more information about Near Wall
Treatments in the k-epsilon model please refer to Setting Up the k- ε Model
in the User’s Guide.
iv.
4.

Click OK to accept the model and close the Viscous Model dialog box.

Set up your materials for the CFD simulation.
Materials

a.

Create a new material called water using the Create/Edit Materials dialog box (Figure 1.18 (p. 34)).
Materials →
i.

Fluid → Create/Edit...

Type water for Name.
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ii. Enter the following values in the Properties group box:
Property

Value

Density


1000  

 (Specific Heat)

4216   − 

Thermal Conductivity

0.677

Viscosity

8e-04   − 

−

Figure 1.18 The Create/Edit Materials Dialog Box

iii.

Click Change/Create.

Note
A Question dialog box will open, asking if you want to overwrite air. Click
No so that the new material water is added to the Fluent Fluid Materials
list of materials that originally contained only air.
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Extra
You could have copied the material water-liquid (h2o < l >) from the materials database (accessed by clicking the ANSYS FLUENT Database... button).
If the properties in the database are different from those you want to use,
you can edit the values in the Properties group box in the Create/Edit Materials dialog box and click Change/Create to update your local copy. The
original copy will not be affected.
iv.

Make sure that there are now two materials (water and air) defined locally by examining the
Fluent Fluid Materials drop-down list.

Note
Both the materials will also be listed under Fluid in the Materials task page.
v.
5.

Close the Create/Edit Materials dialog box.

Set up the cell zone conditions for the CFD simulation.
Cell Zone Conditions

Release 14.0 - © SAS IP, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.

35

Chapter 1: Introduction to Using ANSYS FLUENT in ANSYS Workbench: Fluid Flow and Heat Transfer in a
Mixing Elbow

a.

Set the cell zone conditions for the fluid zone.
i.

Select fluid in the Zone list in the Cell Zone Conditions task page, then click Edit... to open
the Fluid dialog box.

Note
You can also double-click a list item in order to open the corresponding dialog
box.
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6.

ii.

In the Fluid dialog box, select water from the Material Name drop-down list.

iii.

Click OK to close the Fluid dialog box.

Set up the boundary conditions for the CFD analysis.
Boundary Conditions
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a.

Set the boundary conditions at the cold inlet (velocity-inlet-large).
Boundary Conditions →

velocity-inlet-large → Edit...

This opens the Velocity Inlet dialog box.

Tip
If you are unsure of which inlet zone corresponds to the cold inlet, you can use
the mouse to probe for mesh information in the graphics window. If you click the
right mouse button with the pointer on any node in the mesh, information about
the associated zone will be displayed in the ANSYS FLUENT console, including the
name of the zone. The zone you probed will be automatically selected from the
Zone selection list in the Boundary Conditions task page.
Alternatively, you can click the probe button ( ) in the graphics toolbar and click
the left mouse button on any node. This feature is especially useful when you
have several zones of the same type and you want to distinguish between them
quickly. The information will be displayed in the console.
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i.

Select Components from the Velocity Specification Method drop-down list.

Note
The Velocity Inlet dialog box will expand.
ii.
iii.

 for X-Velocity.
Retain the default value of 0   for both Y-Velocity and Z-Velocity.

Enter 0.4

iv.

Select Intensity and Hydraulic Diameter from the Specification Method drop-down list in
the Turbulence group box.

v.

Enter 5

vi.

Enter 4 inches for Hydraulic Diameter.

for Turbulent Intensity.
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Note
The hydraulic diameter

 is defined as:

 = 

where  is the cross-sectional area and 

is the wetted perimeter.

vii. Click the Thermal tab.

viii. Enter 293.15
ix.
b.

for Temperature.

Click OK to close the Velocity Inlet dialog box.

In a similar manner, set the boundary conditions at the hot inlet (velocity-inlet-small), using the
values in the following table:
Boundary Conditions →

40

velocity-inlet-small → Edit...

Velocity Specification Method

Components

X-Velocity

0

Y-Velocity

1.2
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c.



Z-Velocity

0

Specification Method

Intensity & Hydraulic Diameter

Turbulent Intensity

5

Hydraulic Diameter

1 in

Temperature

313.15



Set the boundary conditions at the outlet (pressure-outlet), as shown in the Pressure Outlet
dialog box.
Boundary Conditions →

pressure-outlet → Edit...

Note
ANSYS FLUENT will use the backflow conditions only if the fluid is flowing into the
computational domain through the outlet. Since backflow might occur at some
point during the solution procedure, you should set reasonable backflow conditions
to prevent convergence from being adversely affected.
7.

Set up solution parameters for the CFD simulation.

Note
In the steps that follow, you will set up and run the calculation using the task pages
listed under the Solution heading in the navigation pane.
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a. Examine the convergence criteria for the equation residuals.
Monitors →

Residuals → Edit...

i.

Make sure that Plot is enabled in the Options group box.

ii.

Keep the default values for the Absolute Criteria of the Residuals, as shown in the Residual
Monitors dialog box.

iii.

Click OK to close the Residual Monitors dialog box.

Note
By default, all variables will be monitored and checked by ANSYS FLUENT as a
means to determine the convergence of the solution.
b.

Create a surface monitor at the outlet (pressure-outlet)
It is good practice to monitor physical solution quantities in addition to equation residuals when
assessing convergence.
Monitors → Create... (Surface Monitors)
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i.

Retain the default entry of surf-mon-1 for the Name of the surface monitor.

ii.

Enable the Plot option for surf-mon-1.

iii.

Set Get Data Every to 3 by clicking the up-arrow button.
This setting instructs ANSYS FLUENT to update the plot of the surface monitor and write data
to a file after every 3 iterations during the solution.

iv.

Select Mass-Weighted Average from the Report Type drop-down list.

v.

Select Temperature... and Static Temperature from the Field Variable drop-down lists.

vi.

Select pressure-outlet from the Surfaces selection list.

vii. Click OK to save the surface monitor settings and close the Surface Monitor dialog box.
The name and report type of the surface monitor you created will be displayed in the Surface
Monitors selection list in the Monitors task page.
c.

Change the Gradient method.
Solution Methods
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In the Spatial Discretization section of the Solution Methods pane, change the Gradient
to Green-Gauss Node Based. This gradient method is suggested for tetrahedral meshes.
d.

Initialize the flow field.
Solution Initialization
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i.

Keep the default of Hybrid Initialization from the Initialization Methods group box.

ii.

Click Initialize.
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e.

Check to see if the case conforms to best practices.
Run Calculation → Check Case

8.

i.

Click the Mesh and Solver tabs and examine the Recommendation in each. These recommendations can be ignored for this tutorial. The issues they raise will be addressed in later
tutorials.

ii.

Close the Case Check dialog box.

Calculate a solution.
a.

Start the calculation by requesting 300 iterations.
Run Calculation

i.

Enter 300 for Number of Iterations.

ii.

Click Calculate.
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Important
Note that the ANSYS FLUENT settings file (FFF.set) is written before the
calculation begins.

Important
Note that while the program is calculating the solution, the states of the
Setup and Solution cells in the fluid flow ANSYS FLUENT analysis system in
ANSYS Workbench are changing. For example:
•

The state of the Setup cell becomes Up-to-Date and the state of the Solution
cell becomes Refresh Required after the Run Calculation task page is visited
and the number of iterations is specified.

•

The state of the Solution cell is Update Required while iterations are taking
place.

•

The state of the Solution cell is Up-to-Date when the specified number of iterations are complete (or if convergence is reached).

Note
As the calculation progresses, the surface monitor history will be plotted in the
graphics window (Figure 1.19 (p. 47)).

Note
The solution will be stopped by ANSYS FLUENT when the residuals reach their
specified values or after 300 iterations. The exact number of iterations will vary
depending on the platform being used. An Information dialog box will open to
alert you that the calculation is complete. Click OK in the Information dialog box
to proceed.
Because the residual values vary slightly by platform, the plot that appears on
your screen may not be exactly the same as the one shown here.
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Figure 1.19 Convergence History of the Mass-Weighted Average Temperature

You can display the residuals history (Figure 1.20 (p. 48)), by selecting it from the graphics window
drop-down list.
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Figure 1.20 Residuals for the Converged Solution

b.

48

Examine the plots for convergence (Figure 1.20 (p. 48) and Figure 1.19 (p. 47)).
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Note
There are no universal metrics for judging convergence. Residual definitions that
are useful for one class of problem are sometimes misleading for other classes of
problems. Therefore it is a good idea to judge convergence not only by examining
residual levels, but also by monitoring relevant integrated quantities and checking
for mass and energy balances.
There are three indicators that convergence has been reached:
•

The residuals have decreased to a sufficient degree.
The solution has converged when the Convergence Criterion for each variable
has been reached. The default criterion is that each residual will be reduced
−
to a value of less than
, except the energy residual, for which the default
−
criterion is
.

•

The solution no longer changes with more iterations.
Sometimes the residuals may not fall below the convergence criterion set in
the case setup. However, monitoring the representative flow variables through
iterations may show that the residuals have stagnated and do not change with
further iterations. This could also be considered as convergence.

•

The overall mass, momentum, energy, and scalar balances are obtained.
You can examine the overall mass, momentum, energy and scalar balances in
the Flux Reports dialog box. The net imbalance should be less than 0.2 of
the net flux through the domain when the solution has converged. In the next
step you will check to see if the mass balance indicates convergence.

9.

View the list of files generated by ANSYS Workbench.
View → Files
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Figure 1.21 ANSYS Workbench Files View for the Project After Generating a Solution

Note that the status of the Solution cell is now up-to-date.

1.4.6. Step 5: Displaying Results in ANSYS FLUENT and CFD-Post
In this step, you will display the results of the simulation in ANSYS FLUENT, display the results in CFDPost, then review the list of files generated by ANSYS Workbench.
1.

Display results in ANSYS FLUENT.
With ANSYS FLUENT still running, you can perform a simple evaluation of the velocity and temperature contours on the symmetry plane. Later, you will use CFD-Post (from within ANSYS Workbench)
to perform the same evaluation.
a.

Display filled contours of velocity magnitude on the symmetry plane (Figure 1.22 (p. 52)).
Graphics and Animations →

Contours → Set Up...

Note
You can also double-click a list item in order to open the corresponding dialog
box.
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i.

In the Contours dialog box, enable Filled in the Options group box.

ii.

Make sure that Node Values is enabled in the Options group box.

iii.

Select Velocity... and Velocity Magnitude from the Contours of drop-down lists.

iv.

Select symmetry from the Surfaces selection list.

v.

Click Display to display the contours in the active graphics window.
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Figure 1.22 Velocity Distribution Along Symmetry Plane

b.

Display filled contours of temperature on the symmetry plane (Figure 1.23 (p. 54)).
Graphics and Animations →
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Contours → Set Up...
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i.

Select Temperature... and Static Temperature from the Contours of drop-down lists.

ii.

Click Display and close the Contours dialog box.
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Figure 1.23 Temperature Distribution Along Symmetry Plane

c.

Close the ANSYS FLUENT application.
File → Close FLUENT

Important
Note that the ANSYS FLUENT case and data files are automatically saved when
you exit ANSYS FLUENT and return to ANSYS Workbench.
d.

View the list of files generated by ANSYS Workbench.
View → Files
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Figure 1.24 ANSYS Workbench Files View for the Project After Exiting ANSYS
FLUENT

Note the addition of the compressed ANSYS FLUENT case file (FFF-1.cas.gz) and corresponding data file (FFF-1-00236.dat.gz) to the list of files. Also note that the name of
the data file is based on the number of iterations, so your data file name may be different.
2.

Display results in CFD-Post.
a.

Start CFD-Post.
In the ANSYS Workbench Project Schematic, double-click the Results cell in the elbow
fluid flow analysis system (cell A6). This displays the CFD-Post application. You can also rightclick the Results cell to display the context menu where you can select the Edit... option.

Note
The elbow geometry is already loaded and is displayed in outline mode. ANSYS
FLUENT case and data files are also automatically loaded into CFD-Post.
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Figure 1.25 The Elbow Geometry Loaded into CFD-Post

b.

Reorient the display.
Click the blue Z axis on the axis triad in the bottom right hand corner of the graphics display
to orient the display so that the view is of the front of the elbow geometry.

c.

Ensure that Highlighting (

d.

Display filled contours of velocity magnitude on the symmetry plane (Figure 1.26 (p. 58)).
i.

) is disabled.

Insert a contour object using the Insert menu item at the top of the CFD-Post window.
Insert → Contour
This displays the Insert Contour dialog box.
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ii.

Keep the default name of the contour (Contour 1) and click OK to close the dialog box.
This displays the Details of Contour 1 view below the Outline view in CFD-Post. This view
contains all of the settings for a contour object.

iii.

In the Geometry tab, select fluid in the Domains list.

iv.

Select symmetry in the Locations list.

v.

Select Velocity in the Variable list.

vi.

Click Apply.
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Figure 1.26 Velocity Distribution Along Symmetry Plane

e.

Display filled contours of temperature on the symmetry plane (Figure 1.27 (p. 59)).
i.

Click the check-marked box beside the Contour 1 object under User Locations and Plots
to deselect the Contour 1 object and hide the first contour display.

ii.

Insert a contour object.
Insert → Contour
This displays the Insert Contour dialog box.
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iii.

Keep the default name of the contour (Contour 2) and click OK to close the dialog box.
This displays the Details of Contour 2 view below the Outline view.

iv.

In the Geometry tab, select fluid from the Domains list.

v.

Select symmetry in the Locations list.

vi.

Select Temperature in the Variable list.
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vii. Click Apply.

Figure 1.27 Temperature Distribution Along Symmetry Plane

3.

Close the CFD-Post application by selecting File → Close CFD-Post or by clicking the ‘X’ in the top
right corner of the window.

Important
Note that the CFD-Post state files are automatically saved when you exit CFDPost and return to ANSYS Workbench.
4.

Save the elbow-workbench project in ANSYS Workbench.

5.

View the list of files generated by ANSYS Workbench.
View → Files
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Figure 1.28 ANSYS Workbench Files View for the Project After Viewing Results in
CFD-Post

Note the addition of the CFD-Post state file (elbow.cst) to the list of files. For more information
about CFD-Post (and the files associated with it), see the CFD-Post documentation.

1.4.7. Step 6: Duplicating the FLUENT-Based Fluid Flow Analysis System
At this point, you have a completely defined fluid flow system that is comprised of a geometry, a
computational mesh, a CFD setup and solution, and corresponding results. In order to study the effects
upon the flow field that may occur if you were to alter the geometry, another fluid flow analysis is required. One approach would be to use the current system and change the geometry, however you
would overwrite the data from your previous simulation. A more suitable and effective approach would
be to create a copy, or duplicate, of the current system, and then make the appropriate changes to the
duplicate system.
In this step, you will create a duplicate of the original FLUENT-based fluid flow system, then review the
list of files generated by ANSYS Workbench.
1.
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In the Project Schematic, right-click the title cell of the Fluid Flow (FLUENT) system and select Duplicate from the context menu.
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Figure 1.29 Duplicating the Fluid Flow System

Figure 1.30 The Original Fluid Flow System and Its Duplicate

Note
Notice that in the duplicated system, the state of the Solution cell indicates that the
cell requires an update while the state of the Results cell indicates that the cell requires
attention. This is because when a system is duplicated, the case and data files are not
copied to the new system, therefore, the new system does not yet have solution data
associated with it.
2.

Rename the duplicated system to new-elbow.

3.

Save the elbow-workbench project in ANSYS Workbench.

1.4.8. Step 7: Changing the Geometry in ANSYS DesignModeler
Now that you have two separate, but equivalent, FLUENT-based fluid flow systems to work from, you
can make changes to the second system without impacting the original system. In this step, you will
make a slight alteration to the elbow geometry in ANSYS DesignModeler by changing the diameter of
the smaller inlet, then review the list of files generated by ANSYS Workbench.
1.

Open ANSYS DesignModeler.
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Double-click the Geometry cell of the new-elbow system (cell B2) to display the geometry in
ANSYS DesignModeler.
2.
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Change the diameter of the small inlet (velocity-inlet-small).
a.

Select Sketch3, under Extrude1 to open the Details View of the small inlet extrusion.

b.

In the Details View, under Dimensions:1, change the R1 (radius) value from 0.5 inches to
0.75 inches.

c.

Click the Generate button to generate the geometry with your new values.
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Figure 1.31 Changing the Diameter of the Small Inlet in ANSYS DesignModeler

3.

Close ANSYS DesignModeler.

4.

View the list of files generated by ANSYS Workbench.
View → Files
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Figure 1.32 ANSYS Workbench Files View for the Project After Duplicating the System
and Changing the Geometry

Note the addition of the geometry, mesh, and ANSYS FLUENT settings files now associated with
the new, duplicated system.

1.4.9. Step 8: Updating the Mesh in the ANSYS Meshing Application
The modified geometry now requires a new computational mesh. The mesh settings for the duplicated
system are retained in the duplicated system. In this step, you will update the mesh based on the mesh
settings from the original system, then review the list of files generated by ANSYS Workbench.
In the Project Schematic, right-click the Mesh cell of the new-elbow system (cell B3) and select Update
from the context menu. This will update the mesh for the new geometry based on the mesh settings
you specified earlier in the ANSYS Meshing application without having to open the editor to regenerate
the mesh.
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Figure 1.33 Updating the Mesh for the Changed Geometry

It will take a few moments to update the mesh. Once the update is complete, the state of the Mesh
cell is changed to up-to-date, symbolized by a green check mark.
For illustrative purposes of the tutorial, the new geometry and the new mesh are displayed below.
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Figure 1.34 The Updated Geometry and Mesh in the ANSYS Meshing Application

Inspecting the files generated by ANSYS Workbench reveals the updated mesh file for the duplicated
system.
View → Files
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Figure 1.35 ANSYS Workbench Files View for the Project After Updating the Mesh for the
Altered Geometry

1.4.10. Step 9: Calculating a New Solution in ANSYS FLUENT
Now that there is an updated computational mesh for the modified geometry in the duplicated system,
a new solution needs to be generated using ANSYS FLUENT. In this step, you will revisit the settings
within ANSYS FLUENT, calculate another solution, view the new results, then review the list of files
generated by ANSYS Workbench.
1.

Open ANSYS FLUENT.
In the Project Schematic, right-click the Setup cell of the new-elbow system (cell B4) and select
Edit... from the context menu. Since the mesh has been changed, you are prompted as to
whether you want to load the new mesh into ANSYS FLUENT or not. Select Yes to continue, and
click OK when FLUENT Launcher is displayed in order to open ANSYS FLUENT.
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Figure 1.36 ANSYS Workbench Prompt When the Upstream Mesh Has Changed

2.

Make sure that the unit of length is set to inches.
General → Units...

3.

Check the mesh (optional).
General → Check

4.

Revisit the boundary conditions for the small inlet.
Boundary Conditions →

velocity-inlet-small → Edit...

Here, you need to set the hydraulic diameter to 1.5 in based on the new dimensions of the small
inlet.
5.

Reinitialize the solution.
Solution Initialization
Keep the default Hybrid Initialization and click Initialize.

6.

Recalculate the solution.
Run Calculation
Keep the Number of Iterations set to 300 and click Calculate.

7.

Close ANSYS FLUENT.

8.

Revisit the results of the calculations in CFD-Post.
Double-click the Results cell of the new-elbow fluid flow system to re-open CFD-Post where
you can review the results of the new solution.

9.

Close CFD-Post.

10. Save the elbow-workbench project in ANSYS Workbench.
11. View the list of files generated by ANSYS Workbench.
View → Files
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Figure 1.37 ANSYS Workbench Files View for the Project After Viewing the New
Results in CFD-Post

Note the addition of the solution and state files now associated with new duplicated system.

1.4.11. Step 10: Comparing the Results of Both Systems in CFD-Post
In this step, you will create a new Results system in ANSYS Workbench, use that system to compare
the solutions from each of the two FLUENT-based fluid flow analysis systems in CFD-Post at the same
time, then review the list of files generated by ANSYS Workbench.
1.

Create a Results system.
In ANSYS Workbench, drag a Results system from the Component Systems section of the Toolbox
and drop it into the Project Schematic, next to the fluid flow systems.
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Figure 1.38 The New Results System in the Project Schematic

2.

Add the solutions of each of the systems to the Results system.
a.

Select the Solution cell in the first Fluid Flow analysis system (cell A5) and drag it over the Results
cell in the Results system (cell C2). This creates a transfer data connection between the two systems.

Figure 1.39 Connecting the First Fluid Flow System to the New Results System

b.

Select the Solution cell in the second Fluid Flow analysis system (cell B5) and drag it over the
Results cell in the Results system (cell C2). This creates a transfer data connection between the
two systems.

Figure 1.40 Connecting the Second Fluid Flow System to the New Results System

3.

70

Open CFD-Post to compare the results of the two fluid flow systems.
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Now that the two fluid flow systems are connected to the Results system, double-click the Results
cell in the Results system (cell C2) to open CFD-Post. Within CFD-Post, both geometries are displayed side by side.

Figure 1.41 CFD-Post with Both Fluid Flow Systems Displayed

a.

Re-orient the display.
In each view, click the blue Z axis on the axis triad in the bottom right hand corner of the
graphics display to orient the display so that the view is of the front of the elbow geometry.

Important
Alternatively, you can select the synchronization tool (
) in the 3D Viewer
Toolbar to synchronize the views, so that when you re-orient one view, the
other view is automatically updated.
b.

Display filled contours of velocity magnitude on the symmetry plane.
i.

Insert a contour object.
Insert → Contour
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This displays the Insert Contour dialog box.
ii.

Keep the default name of the contour (Contour 1) and click OK to close the dialog box.
This displays the Details of Contour 1 view below the Outline view in CFD-Post. This view
contains all of the settings for a contour object.

iii.

In the Geometry tab, select fluid in the Domains list.

iv.

Select symmetry in the Locations list.

v.

Select Velocity in the Variable list.

vi.

Click Apply. The velocity contours are displayed in each view.

Figure 1.42 CFD-Post Displaying Velocity Contours for Both Geometries

c.
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Display filled contours of temperature on the symmetry plane.
i.

Deselect the Contour 1 object under User Locations and Plots in CFD-Post to hide the first
contour display.

ii.

Insert another contour object.
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Insert → Contour
This displays the Insert Contour dialog box.
iii.

Keep the default name of the contour (Contour 2) and click OK to close the dialog box.
This displays the Details of Contour 2 view below the Outline view in CFD-Post.

iv.

In the Geometry tab, select fluid in the Domains list.

v.

Select symmetry in the Locations list.

vi.

Select Temperature in the Variable list.

vii. Click Apply. The temperature contours are displayed in each view.

Figure 1.43 CFD-Post Displaying Temperature Contours for Both Geometries

4.

Close the CFD-Post application.

5.

Save the elbow-workbench project in ANSYS Workbench.

6.

View the list of files associated with your project using the Files view.
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View → Files

Figure 1.44 ANSYS Workbench Files View for the Project After Viewing the Combined
Results in CFD-Post

Note the addition of the Results system and its corresponding files.

1.4.12. Step 11: Summary
In this tutorial, portions of ANSYS Workbench were used to compare the fluid flow through two slightly
different geometries. ANSYS DesignModeler was used to create a mixing elbow geometry, ANSYS
Meshing was used to create a computational mesh, ANSYS FLUENT was used to calculate the fluid flow
throughout the geometry using the computational mesh, and CFD-Post was used to analyze the results.
In addition, the geometry was altered, a new mesh was generated, and a new solution was calculated.
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Finally, ANSYS Workbench was set up so that CFD-Post could directly compare the results of both calculations at the same time.
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